Untitled Document

О редакторе и справке ...

Редактор уровней для Z1, появился в 1998 году. Он был включен в диск с дополнительными миссиями к Z1.

На самом деле это был не просто Add-on. Игра была переведена из DOS4GW в Windows 95. Естественно появились некоторые новые опции, например, можно настраивать скролинг мыши и т.д. Очень существенным дополнением является редактор уровней.

Неизвестно по каким причинам, но на нашем рынке этого диска НЕ БЫЛО! (Во всяком случае я не встречал.) Первые сообщения о том, что он существует, я получил на сайтах http://www.zsteelsoldiers.narod.ru и http://www.zuniverse.f2s.com. И это было осенью 2001 года!!!

Кстати, всем кто не был на этих сайтах, настоятельно рекомендую их посетить. Оба они посвящены продолжению Z1 - Z Steel Soldiers, однако там есть материалы и по первой игре. Сделаны оба с большой любовью. Первый сайт русскоязычный (создатель Mosa Int), второй англоязычный, он выполнен очень профессионально и его посещение доставляет просто удовольствие.

В настоящий момент в моем распоряжении оказалась немецкая версия (в общем-то только ее и можно найти) поэтому я решил облегчить жизнь Zедолюбов, переведя справку к редактору и добавив кое-что от себя.

Выражаю глубокую признательность Mosa Int, за помощь в приобретении диска, а так же за ценные советы и замечания по этой справке.

Внимание!

  • Я не являюсь большим специалистом по немецкому языку, поэтому могут быть какие-то неточности.
  • Прошу Всех, заметивших что-то неправильное, или имеющих полезный опыт, или какие-то предложения/пожелания - слать их по адресу: v_bolvin@mail.ru

В перспективе этот редактор будет полностью русифицирован, поэтому даются сразу два интерфейса - русский и немецкий (как самый распространенный). Русифицированный вариант редактора, вероятно, можно будет найти на указанных выше сайтах и конечно на нашем http://www.GeneralZod.narod.ru.

Также попробуем сделать на этом редакторе карты для одиночной игры. Если получиться, то сообщим об этом и я добавлю новую главу в справку.

/* Всем приятной работы */

Болвин Володя (BallWin), Kilp-Evr Std.


Обзор

Z-EDITOR дает Вам возможность создавать абсолютно новые уровни, на которых Вы можете сражаться со своими друзьями по Сети.

Вначале редактором генерируется совершенно пустая заготовка карты, размер которой Вы задаете. По периметру она окружена непроницаемым валом. Количество Фортов соответствует количеству заданных игроков. Они будут размещены на карте автоматически. Кроме того, можно по желанию изменять границы отдельных областей. Чтобы превратить заготовку в полноценный уровень нужно, как минимум:

  • Построить дороги, связав их в единую сеть.
  • Расставить своих и вражеских бойцов в стартовую позицию.


Общие указания

По карте можно перемещаться, используя курсор, с нажатой левой кнопкой, или, для более быстрого перемещения, с нажатой правой кнопкой. Если вы в это время работаете с какой-то выбранной кистью (под кистью подразумеваются любые объекты, выбранные на панели управления или из меню), то можете перемещаться по карте, просто двигая курсор в нужную сторону (естественно пока не кончится рабочее поле редактора).

Небольшой экран Мини карты показывает вам в уменьшенном размере ваш будущий уровень, причем вносимые изменения отображаются немедленно. Светлой рамкой выделяется на нём область, над которой вы сейчас работаете. Щелчок левой кнопкой мыши на любом месте Мини карты перенесет вас в соответствующую позицию на рабочей карте.

Вы можете активировать Форты, здания и оружие обводя их рамкой при помощи мышки с нажатой левой кнопкой.

Щелкнув на объекте правой кнопкой мыши, получите окно диалога, в котором можно изменять свойства объектов (для каждого естественно свой набор).

Все что вы натворили в редакторе можно отменить. Для этого нужно выбрать "Отмена" в меню Правка непосредственно сразу после ошибочной операции.

Почти обо всех непонятных функциях можно получить справку, если нажать, находясь в диалоговом окне, клавишу F1.


Часто задаваемые вопросы про Z

Здесь помещены наиболее интересные вопросы по Z1 из Российского Z-Форума, или присланные на мой e-mail. Форум находится на сайтах, адреса которых я давал в разделе "О редакторе и справке…".

Имена изменены, так как некоторые вопросы были заданы в личной переписке, и я не успел получить разрешения на публикацию под настоящими. Можете обратиться к товарищам, если имеете более полный ответ, через меня.

Kamera : … в среду я купил себе Z_Addon попытался в него сыграть но ничего не получилось… не запускается …Обидно.

Ответ: Конечно покупать пиратские диски нехорошо, но если больше взять негде, то … Мой вариант add-on был прислан мне Mosa Int, и я предполагаю, что он такой же как и любой другой в нашей стране на сегодняшний день. Если это так, то порядок действий следующий:

1) создай на диске С папку Z. (Советую сначала поставить на диск С старую версию игры Z, а затем в нее поставить add-on. В этом случае в игре будут нормальные английские звуки).

2) раскрой в эту папку add-on.

3) зарегистрируй add-on ( файл z_regfile.reg ).

4) запусти файл Z.exe, если получаешь сообщения об ошибках - не обращай внимания.

5) далее запускай файл winz.exe, тут самое интересное - он выдает стандартное окошко Windows с предупреждением об отсутствии элемента и т.д. В этом окне нужно нажать кнопку "ПРОПУСТИТЬ".

После этого все должно загрузиться как ни в чем не бывало.

ProfesZor: … Ох если б у меня это дело работало... Вин 2000 у меня, ничего старого не пашет...

Ответ: Это тяжелый случай. Под Windows 2000 ни игра, ни редактор не идут. Нет проблем в Windows95, Windows98, про Windows Me ничего сказать не могу, не пробовал. Выход - воспользоваться загрузочным менеджером и поставить 2 системы.

Alexey Kav: Не знает ли кто, чем можно смотреть видео ролики к Z1?

Ответ: К большому сожалению ничем кроме как играть в игру просмотреть их нельзя. Используйте старый, проверенный способ - заканчивая уровень, на последних секундах записывайте игру. Сначала скопируйте куда ни будь в папку все пустые заготовки для сохранения (файлы Save0.z, ..., Save9.z). Пустая заготовка занимает 43 байта, а заполненная - всегда 563 Кб. После этого можно сохранить концовки 10 игр. Затем перепишите все заполненные концовки в другую папку и из первой выложите обратно в директорию с игрой пустые сейвы. Заполняйте их концовками оставшихся 10 игр. Все. У вас получилось 20 сохраненных концовок и теперь, в приступе ностальгии, всегда можно посмотреть на любимых героев. Других способов не знаю. Увы…

Finch: … Слышал про то, что где-то есть вариант Z от первого лица …

Ответ: Да, существует такой проект Z-Unreal. Суть в следующем, попытаться сделать на основе Unreal карты, в которых будут использоваться правила Z1. Т.е. карта поделена на районы, в которых стоят фабрики и выпуск ботов на них начинается только после того, как твои бойцы "захватывают" флаг этой территории. Выпускаются тройками. Пока ограничение по количеству не в 50, как в Z1, а в 19 бойцов за каждую сторону (18 ботов и человек). Во всяком случае интересно повоевать со своими железными товарищами… Можете принять участие. Трудности проекта, в основном, заключаются во внедрении Zедообразных моделей в Unreal. Необходимо иметь представление о 3D моделировании. Сам редактор Unreal достаточно простой. По нему много информации в Интернете. Если хотите принять участие, но не знакомы с 3D моделированием, то могу посоветовать отличный электронный учебник Mosa Int по 3D Max. Написан простым понятным языком человеком, который знал о чем пишет. Думаю, что с его помощью за 2-3 недели можете приступать к созданию собственных моделей и сцен. Не знаю где его можно купить. Мне он сам его прислал. Просите у него лично или ищите на его сайте.

Pavlun: …где у Вас на сайте можно скачать книгу о похождениях Алана и Брэда?

Ответ: У Вас не совсем верная информация. Это проект - "Открытая книга". Он заключается в том, что Zедолюбы, умеющие излагать свои мысли, могут поучаствовать в написании истории о похождениях двух друзей. На сайте выкладываются отдельные главы, затем, нам присылают варианты возможного продолжения. Мы их рассматриваем, согласовываем и добавляем к тому, что уже написано. Возможно, из этого когда-нибудь получиться книга. Интересно, что согласно получившейся на сегодняшний день истории, наши старые друзья не всегда были роботами. Оказывается в будущем научились "копировать" мозг человека в "железо". Умирающие по какой то причине люди получили шанс продолжить собственное существование в виде машины. Таким образом, человек как вид стал существовать в двух формах. Мало того, биологическая часть жизни - была, как правило, короче "железной". Это вызвало конфликт между двумя формами, ведь "железных" становилось все больше. Проблема была решена тогда, когда появился способ относительно быстрого перемещения в глубокий космос. Дело в том, что выдержать такой способ перемещения смогли только "железяки". Так на далеких звездах оказалась только вторая форма жизни хомо сапиенс, а солнечная система осталась колыбелью биологического вида и стала "поставщиком" "железных" в другие галактики… Так что наши друзья отнюдь не просто роботы. Это объясняет почему они такие балбесы... А вот роботы, которые производятся на планетах, - совсем другое дело. В общем об этом можно долго рассказывать…


Меню

В этом разделе будут показаны отдельные пункты меню редактора.

Даются два варианта - русский и немецкий (самый распространенный). Немецкий показан в том виде, в котором его увидит на экранах своих мониторов большинство геймеров (т.е. нечитабельным).

Русский интерфейс
Немецкий интерфейс


Меню : Файл

Меню "Файл" выполняет свои обычные функции: позволяет вам начать работу над новой картой, открыть имеющуюся, сохранить работу и выйти.

Русский интерфейс
Немецкий интерфейс


Файл : Новый ...

Выбрав этот пункт меню вы начинаете строительство новой карты. Для этого, в появившемся диалоговом окне, необходимо задать несколько параметров:

· Величину карты в блоках от 16x16 пикселей. Максимальная величина блока составляет 64x64.

· Тип территории, фактически планету, на которой Ваша карта будет находиться.

· Количество Игроков. Точно такое же количество Фортов будет автоматически создано на заготовке. Учтите, что потом это значение изменить нельзя!

· Принимайте решение - устраивает ли вас то, как компьютер поделил карту на районы. Можете указать количество районов, которое Вы желаете. Так как для этого имеется некоторое минимальное значение, то их количество также воздействует на минимальную величину всего уровня.


Файл : Сохранить как …

Если вы первый раз сохраняете свою работу, или если вы выбрали пункт меню Файл: "Сохранить как...", появляется диалоговое окно, показывающее список пустых слотов, в которые можно сохранять вашу карту. Название каждого слота указывает на то, какой уровень там храниться. Если там пусто, то слот называется "Свободным" (Empty).

После того, как выбрали пустой слот, можете напечатать его название и нажать кнопку сохранить. Если в этом слоте что-то есть, то появиться предупреждение.

Для каждого вида карты (на 2-х, 3-х или 4-х игроков) имеется 20 свободных слотов, в которые вы можете сохраняться.

При сохранении редактор автоматически проверяет готовность вашей карты к игре. Если все сделано правильно, то ваш уровень появляется в списке имеющихся в распоряжении уровней, в случае, если Вы играете за красных, то есть если являетесь "сервером" (если точно хотите быть сервером, то держите клавишу Shift нажатой, в момент, когда нажимаете "Связаться").

Если уровень не готов, он все же запишется, но Вы получите сообщение об имеющихся с ним проблемах и само собой поиграть в него не получиться.


Файл : Открыть

Здесь все просто. Показывается список уровней, нажмите на имя уровня, который Вы хотите загрузить и после этого на "Открыть".

Пункт "Последняя игра" содержит последний вызываемый самодельный уровень в который вы играли.

Так автоматически можно редактировать уровень, который пересылали вам при игре по сети другие игроки.

Если Вы хотите сохранить эти уровни, то должны выбрать слот и выполнить действия по сохранению.


Меню : Правка

В этой секции можно отменить последнее неправильное действие, или вернуть исходное состояние.

Русский интерфейс
Немецкий интерфейс

Пункт "Режим" имеет в своем составе подменю, с помощью которого можно вызвать различные инструменты для редактирования карты:

Русский интерфейс

(в принципе повторяет большую часть Панели инструментов)
Немецкий интерфейс


Меню : Вставка

В этом пункте меню Вы получаете доступ к оставшейся части инструментов, не представленных в меню "Правка".

 Русский интерфейс
Немецкий интерфейс

Такой же набор присутствует на Панели Инструментов.


Меню : Карта

Позволяет получить подробную информацию о создаваемом уровне, по состоянию на текущий момент. По щелчку на этом пункте меню выводится диалоговое окно, в котором эта информация отображается.

Такое же окно выводится при нажатии на иконку инструмента "Информация", в одноименном разделе справки дана более подробная информация о содержании этого диалогового окна.

Русский интерфейс
Немецкий интерфейс


Панель инструментов

Ландшафт

Темный ландшафт

Вода

Дороги

Горы

Флаги

Мосты

Свободное оружие

Декор

Здания

Стартовая позиция

Информация


Правка : Ландшафт

Выбрав этот инструмент, вы можете добавлять поверхность того вида, какой заказывали при установке свойств новой карты (т.е. в зависимости от вида планеты). Этот инструмент нужен, как правило, тогда, когда необходимо уничтожить лишние клетки воды или дороги, хотя конечно легче их убрать, щелкая, например, на ненужной клетке воды правой кнопкой мыши.

После выбора этого инструмента курсор изменяется на квадрат, который показывает, какая площадь будет покрыта.

В оригинале на немецком языке написано, что можно увеличивать и уменьшать размер этой "кисти" нажимая на панели клавиши + или -.

(Я пробовал - ничего не происходит, хотя возможно нужно пробовать в Win95 - прим. BallWin).


Правка : Темный ландшафт
Это чисто косметический инструмент, который просто улучшает внешний вид вашей карты, так сказать для разнообразия. Функционирует точно так же как и инструмент "Ландшафт".

Курсор превращается в квадрат, показывающий, какая площадь будет покрыта. Можно увеличивать или уменьшать размер этой площади, если нажимать + или - .

"Темный ландшафт" не ставиться на некоторые поверхности, например на воду и дороги.

Если вам вдруг потребовалось провести через "Темный ландшафт" дорогу или воду, просто, при выбранном инструменте "Темный ландшафт", нажимайте на ненужном участке правую кнопку мыши. А можно выбрать инструмент "Ландшафт" и покрыть им территорию в нужном месте и уже потом проводить мелиорацию, или дорожные работы.


Правка : Горы

Выбрав этот инструмент, щелкните левой кнопкой мыши в том месте, где вы хотели бы увидеть свой горный хребет. Курсор, имеющий форму квадрата, может быть увеличен или уменьшен при нажатии + или -.

Если гора поставлена ошибочно - установите курсор, при выбранном инструменте "Горы", над ней и нажмите правую кнопку мыши. Гора уберется автоматически в пределах квадрата курсора.

Горы образуют на карте барьеры, которые могут быть разрушены только определенными видами оружия, такими как танки, гранатометчики (Toughts, в просторечии Табсы), пушки, или просто любыми бойцами, имеющими гранаты.

Карта по краям всегда окружена валом из гор, к которым нельзя добавить свои горы вплотную.

Назначение гор - создать препятствия для прохода в определенных направлениях. С их помощью можно регулировать потоки воюющих армий. Чем больше ширина хребта, тем дольше он сможет противостоять разрушению и тем больше времени потратит подразделение на проход через него. Отсюда вывод - стройте свои горные массивы с умом. Они не только украшают внешний вид карты, но и оказывают очень сильное влияние на игровой процесс.

Выбрать инструмент "Горы" можно еще из меню "Правка".


Правка : Дороги

Без дорог - уровня у вас не получится! Так что придется заниматься дорожным строительством.

Для начала выбирайте на Панели инструментов "Дороги", или одноименный пункт из меню "Правка". Курсор принимает квадратную форму. Определяете место начала вашего дорожного полотна и тянете курсор в нужную сторону с нажатой левой кнопкой мыши. Пока на этом месте можно строить дорогу - появляющаяся рамка будет зеленого цвета. Как только вы попадаете на область, где дорогу построить невозможно - рамка (причем вся) становиться красного цвета.

Дороги нельзя строить через здания, предметы, элементы декораций и еще много через чего. Исходя из этого, советую сначала на чистой карте построить свою дорожную сеть, а затем заниматься вопросами размещения всего остального.

Боевые единицы передвигаются по дорогам значительно быстрее, чем по другой местности, поэтому, если в заданном единице направлении будет дорога, она автоматически пойдет по ней. Учитывайте это при планировании уровня...

Если нужно убрать ненужный кусок дороги - нажимайте правую кнопку мыши при выбранном инструменте "Дороги". Если этот кусок был создан только что - нажимайте кнопку "Отменить" (собственно, как и в любом другом редакторе). .

При проектировании дорожной сети избегайте тупиков! (Либо наоборот - используйте их для создания подлости противникам; дело в том, что бойцы, попав в тупик, будут долго стоять и думать, что им делать дальше...) Старайтесь пропустить дорогу недалеко от важных деталей карты: флагов, зданий, и т.д. Соединяйте дороги в единую сеть, чтобы с любой ветки можно было бы попасть куда угодно.

Соединения 2-х дорог имеют строгие ограничения. Например, если 2 дороги параллельны, то должно быть как минимум 2 блока расстояния между ними, чтобы соединение стало возможным. Все соединения должны быть полными квадратами.


Правка : Флаги

Каждый район на карте должен иметь свой флаг, причем один единственный. Собственно к этому сводится вся игра - захват флагов означает захват территории, ну не мне вам рассказывать...:). На карте не может быть районов, не имеющих флага. Всего на карте может размещаться до 64 района!!! Можно добавлять новую область, если нажать на пустом районе левую кнопку мыши и тащить появившуюся рамку.

Можно изменять границы уже существующей области точно так же. Просто подведите курсор с выбранным инструментом "Флаги" к границе существующей области. Он изменит форму на стандартную форму Windows курсора, применяемую при изменении размеров окон. Нажмите левую кнопку мыши и тащите рамку в нужную сторону. Учтите, что границы не пересекают имеющиеся в районе флаги и другие объекты, поэтому добавление и изменение границ должно быть одним из первых действий с вашей картой.

Для того чтобы установить флаг в нужное место нужно выбрать инструмент "Флаги" подвести курсор в нужное место на пустом районе (без другого флага) и нажать левую кнопку мыши. Если же в районе уже существует флаг, то тогда просто подводите к нему курсор (с инструментом "Флаги"), нажмите левую кнопку мыши и тащите его туда, куда вам нужно. Как уже говорилось, перетащить флаг "за границу" не удастся, кроме того, нельзя устанавливать флаг на предметы и рядом с объектами, если границы их (т.е. флага и объекта) пересекаются.

Удалить флаг, например, для создания пустого района, можно щелкнув по нему правой кнопкой мыши, и в появившемся диалоговом окне с информацией о районе, выберите "Пусто". Если флаг только что был установлен, можно просто воспользоваться инструментом "Отмена", или воспользоваться одноименным пунктом из меню "Правка".


Правка : Вода

При выборе инструмента "Вода", курсор становится квадратом, который показывает размеры площади покрываемой водой при однократном использовании. Эту площадь (т.е. размеры курсора) можно увеличивать или уменьшать, если нажимать +, или -. Одно нажатие левой кнопки мыши на нужном месте располагает в нем поверхность, заполненную водой.

Нельзя располагать воду на зданиях и объектах.

Для быстрого передвижения ваших отрядов через водные преграды нужно строить мосты. Чтобы строить мосты - используйте инструмент "Мосты".

Убрать лишнюю воду, можно щелкая на ненужном квадрате с водой правой кнопкой мыши, или (если ненужный элемент создан только что) нажать кнопку "Отмена". В этом случае элемент воды, входящий в квадрат курсора, будет убран автоматически.

Транспортные средства не могут передвигаться по воде, однако роботы могут, правда, с очень низкой скоростью. Если вы создали достаточно широкую поверхность воды, то на середине получается значительная глубина. В этом случае на некоторых планетах (например, на планете "Джунгли") в ней может водиться всякая живность и вашего солдата могут просто сожрать. На планете "Джунгли" есть крокодилы, а на планете "Город" вроде бы водятся червяки, обожающие роботов, если я не ошибаюсь.


Правка : Мосты

С помощью мостов Вы можете соединить 2 участка дороги (повторяю для тех, кто на бронепоезде: именно ДОРОГИ), разделенных водой. Для этого нужно выбрать инструмент "Мосты" перевести квадрат, в который превращается курсор на конец первого участка дороги, причем охватить его ПОЛНОСТЬЮ, и, нажав левую кнопку мыши тянуть рамку до начала второго участка. Причем эти два участка должны находиться строго друг против друга и охват начала второго участка дороги должен быть полным. Если вы все сделали правильно, рамка будет зеленой. Если нет - останется красной.

Кроме того, учитывайте то, что мосты могут быть определенной минимальной длины, т.е. если попытаться сделать его меньше минимума, то ничего не получиться. Это потому, что имеется определенные картинки мостов и меньше самой маленькой, конечно, поставить не получиться.

Всего на карте может быть не более 12 мостов.

Чтобы редактировать свойства моста, или убрать его нужно нажать правую кнопку мыши на нем, тогда выйдет диалоговое окно в котором будут следующие пункты:

Прочность - показывает сколько пробоин может выдержать данный мост до взрыва.

Ремонт - за какое время мост может быть восстановлен (даже без машин для ремонта).

Разрушение - если отметить этот пункт, то мост будет взорван при старте уровня.

Если, по ходу игры, мост будет взорван, то все, находящиеся на нем юниты, погибнут.

Инструмент "Мосты" можно выбрать на Панели инструментов, либо из меню "Правка".


Форт

Форт является особым видом зданий. На карте может быть только такое количество фортов, сколько было задано игроков при создании новой карты. Вы не можете ни удалить какой либо форт, ни добавить дополнительный. Однако можно изменять свойства отдельного форта и переносить его на новое место.

Можно изменить Прочность форта (т.е. количество попаданий до взрыва) и производительность. Однако так как все форты в игре должны быть одинаково сильны, изменение свойств одного из них ведет к автоматическому изменению свойств остальных. Изменения вступают в силу после подтверждения.

Если Вы готовы - жмите "ОК", либо "Отменить", если не желаете ничего изменять.

Еще раз повторяю - возможности снести форт в редакторе НЕ СУЩЕСТВУЕТ (а в игре очень даже можно; берете несколько тяжелых танков, кучу роботов…:). Заранее планируйте свою работу и задавайте нужное количество игроков в диалоговом окне при создании новой карты.


Инструменты : Здания

Нажав на этот инструмент вы попадаете в диалоговое окно, в котором должны выбрать нужный Вам элемент. Для просмотра списка доступных элементов нажмите внизу клавишу ">" для просмотра вперед и клавишу "<" для просмотра в обратном направлении. Когда список заканчивается соответствующая стрелка становится серой и эта кнопка будет недоступной.

Кнопка "ОК" устанавливает заказанное здание на месте, где в данное время находится курсор, если нажать левую кнопку мыши.

После установки здания, можно изменить его свойства. А именно:

Прочность - Сколько повреждений может выдержать здание, прежде чем будет разрушено.

Ассортимент - чем более высокая цифра установлена, тем больше разновидностей возможной продукции будет выпускать ваша фабрика.

Ремонт - сколько времени потребуется на автоматический ремонт здания после разрушения. (В add-on больше нет наших любимых юнитов Crane, а жаль....)

Переключиться из режима установки зданий на любой другой, можно выбрав новую кисть на Панели инструментов, либо выбрав соответствующий пункт меню "Вставка".

На карте может быть одновременно до 35 зданий, при этом форты считаются тоже. Например, при выборе карты на четырех игроков у вас будет 4 форта, следовательно, вы можете установить еще 31 здание, а, например на двоих игроков будет 2 форта и есть возможность установить 33 здания.

Чтобы удалить ненужное строение щелкните по нему правой кнопкой мыши.


Инструменты : Стартовая позиция

Этот инструмент предназначен для расстановки стартовых сил противников. Т.е. то, что Вы и ваши противники будете иметь вначале игры.

Нажав на иконку, вы попадаете сначала в диалоговое окно, в котором нужно выбрать нужный Вам элемент. Для просмотра списка доступных элементов нажмите внизу клавишу ">" для просмотра вперед и клавишу "<" для просмотра в обратном направлении. Когда список заканчивается соответствующая стрелка становится серой и недоступной.

Кнопка "ОК" поместит выбранную боевую единицу в позицию курсора. Переместите курсор туда, где она должна находится (по вашему представлению), и нажмите левую кнопку мыши. Выбор стартовых единиц начинается с КРАСНОЙ АРМИИ. После размещения первой единицы, точно такую же предлагается разместить для СИНЕЙ АРМИИ и так далее, по числу игроков, для каждого будет предложено установить такую же. Это для того, чтобы все армии имели одинаковые стартовые условия. Экран карты автоматически переходит к форту нужного цвета. Если попытаться закончить процесс расстановки до того, как выбранная единица будет представлена у всех игроков, вы получите соответствующее предупреждение и вся расстановка (этой единицы) будет аннулирована.

Если будут выбраны пушки, то вы можете расположить их на форте, на одной из четырех башен, или на любом другом месте территории, на которой стоит форт.

Как только вы начали расстановку для какой-то выбранной единицы, вы должны ее закончить. Для того чтобы заняться чем-то другим, нужно выбрать новый инструмент на панели задач или из соответствующего меню.


Инструменты : Свободное оружие

Этот инструмент дает вам возможность расставить на карте орудия и транспортные средства, которые ваши бойцы могут занимать. Для этого они должны добраться до них первыми.

Нажав на этот инструмент, вы попадаете сначала в диалоговое окно, в котором нужно, для начала, выбрать нужный Вам элемент. Для просмотра списка доступных элементов нажмите внизу клавишу ">" для просмотра вперед и клавишу "<" для просмотра в обратном направлении. Когда список заканчивается соответствующая стрелка становится серой и недоступной.

Кнопка "ОК" размещает выбранное оружие в позицию курсора. Затем вы перемещаете курсор в место, где хотите его установить и нажимаете левую кнопку мыши.

Выход из этого режима работы и переход к другому осуществляется выбором нового инструмента в панели задач или из соответствующего пункта меню.

Размещайте свободное оружие там, где роботы могут до него добраться!

Всего на карте может быть 150 объектов одновременно, причем за объекты считаются как декоративные элементы, так и свободное оружие.

Чтобы изменить уже установленное оружие, щелкните на нем правой кнопкой мыши, тогда в диалоговом окне вы можете его поменять на другое, или удалить.


Инструменты : Декор

С помощью этого инструмента можно разнообразить карту различными декоративными элементами, от деревьев, до будок для местной фауны. Кроме того они могут выполнять функцию создания препятствий для прохода в каком то направлении. Эти препятствия могут быть разрушены только определенными видами оружия (танки, гранаты, пушки).

Нажав на этот инструмент Вы попадаете сначала в диалоговое окно, в котором можно выбрать нужный Вам элемент. Для просмотра списка доступных элементов нажмите внизу клавишу ">" для просмотра вперед и клавишу "<" для просмотра в обратном направлении. Когда список заканчивается соответствующая стрелка становится серой и эта кнопка будет недоступной, пока не начнется просмотр в обратном направлении.

Будки для живности нужно размещать на карте как минимум две, но не более 50.

При распределении объектов исходите из того, что на карте может быть не более 150 объектов и в эту цифру входит количество свободного оружия.

Для изменения декоративного элемента на другой щелкните на нем правой кнопкой мыши. В появившемся диалоговом окне выберите новый, либо нажмите "Удалить", если он вам не нужен.


Информация по карте

Этот пункт меню дает возможность Вам изменять название карты и просмотреть такие детали как ее величина, количество областей, зданий и предметов.

Нажав иконку этого инструмента, или выбрав в меню "Карта" - "Информация", вы попадаете в диалоговое окно "Информация по карте".

Зачем собственно оно нужно? В первую очередь для того, чтобы отслеживать достижение максимальных значений для определенных типов составляющих карты. Например на карте любого размера может быть только 12 мостов. Если вы пытаетесь ставить мост и ничего не получается, посмотрите - не достигли ли вы максимальной величины.

То же самое (и даже в большей степени) касается количества обьектов.

 Русский интерфейс
Немецкий интерфейс


Меню : Карта

Позволяет получить подробную информацию о создаваемом уровне, по текущему соотоянию. По щелчку на этом пункте меню выводится диалоговое окно, для просмотра.

Такое же окно выводится при нажатии на иконку инструмента "Информация", в одноименном разделе справки дана более подробная информация о содержании этого диалогового окна.

Русский интерфейс
Немецкий интерфейс


Меню : Справка

Меню справка отвечает за вывод информации о работе с редактором, или краткие сведения об авторах, времени создания и т.д. программы.

Если у вас русский вариант редактора, то будет выведена эта справка, если же немецкий, то, соответственно, и справка будет немецкая.

 Русский интерфейс
Немецкий интерфейс


Диалоговые окна

В этом разделе я поместил справку по основным диалоговым окнам редактора.

На тот случай, если у Вас нет русского редактора, будут даны и варианты и с русским и немецким (самым распространенным) текстом.


Диалог : Свойства моста

При создании моста, или нажатии правой кнопки на уже существующем мосте, выводится диалоговое окно, в котором можно задавать его свойства.

Обьяснения опций даны в разделе справки "Мосты".

Русский интерфейс
Немецкий интерфейс


Диалог : Свойства новой карты

При создании новой карты Вам предлагается задать ее свойства.

Что это за свойства можно уточнить, если непонятно, в разделе справки "Создание карты".

Русский интерфейс
Немецкий интерфейс


Диалог : Сохранить как ...

При первом сохранении карты, или при выборе пункта меню "Сохранить как ..." вам предлагается выбрать пустой слот, задать название сохраняемой карте и указать ее тип..

Обьяснения даны в разделе справки "Сохранение".

Русский интерфейс
Немецкий интерфейс


Диалог : Свойства Здания

При нажатии иконки "Здания" на Панели инструментов, или через соответствующий пункт меню "Вставка", Вам предлагается выбрать его тип, указать прочность, скорость автоматического ремонта, количество выпускаемой продукции.

Обьяснения даны в разделе справки "Здания".

Русский интерфейс
Немецкий интерфейс


Диалог : Информация о территории

Если, при выбранном инструменте "Флаги", вы нажмете правую кнопку мыши на одном из флагов, то получаете окно информации о данной территории.

Обьяснения даны в разделе справки "Флаги".

Русский интерфейс
Немецкий интерфейс